using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:href=|src=|url\()(?:[\"",']?)(.*image3\.png)[\"",',\)]+?";
string input = @"<!DOCTYPE html>
<html lang=""en"">
<head>
<meta charset=""utf-8"" />
<title></title>
<meta name=""description"" content="" />
<meta name=""viewport"" content=""width=device-width, initial-scale=1, maximum-scale=1"" />
<meta http-equiv=""X-UA-Compatible"" content=""IE=edge"">
<link rel=""stylesheet"" type=""text/css"" href=""style.css"" />
</head>
<body>
<div class=""wrapper"">
<img src=""image1.png"" alt=""description goes here"">
<img src=""image2.png"" alt=""description goes here"">
<img src=""image3.png"" alt=""description goes here"">
</div>
<p>This ""image3.png"" is not linked so it should be ignored</>
<p>This ""app.js"" is not linked so it should be ignored</>
<p>This ""style.css"" is not linked so it should be ignored</>
<script src=""app.js""></script>
</body>
</html>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}