use strict;
my $str = '<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8" />
<title></title>
<meta name="description" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="stylesheet" type="text/css" href="style.css" />
</head>
<body>
<div class="wrapper">
<img src="image1.png" alt="description goes here">
<img src="image2.png" alt="description goes here">
<img src="image3.png" alt="description goes here">
</div>
<p>This "image3.png" is not linked so it should be ignored</>
<p>This "app.js" is not linked so it should be ignored</>
<p>This "style.css" is not linked so it should be ignored</>
<script src="app.js"></script>
</body>
</html>
';
my $regex = qr/(?:href=|src=|url\()(?:[\",']?)(.*image3\.png)[\",',\)]+?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}