import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:href=|src=|url\\()(?:[\\\",']?)(.*image3\\.png)[\\\",',\\)]+?";
final String string = "<!DOCTYPE html>\n\n"
+ "<html lang=\"en\">\n\n"
+ "<head>\n"
+ " <meta charset=\"utf-8\" />\n"
+ " <title></title>\n"
+ " <meta name=\"description\" content=\"\" />\n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1, maximum-scale=1\" />\n\n"
+ " <meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\">\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"style.css\" />\n"
+ "</head>\n\n"
+ "<body>\n"
+ " <div class=\"wrapper\">\n"
+ " <img src=\"image1.png\" alt=\"description goes here\">\n"
+ " <img src=\"image2.png\" alt=\"description goes here\">\n"
+ " <img src=\"image3.png\" alt=\"description goes here\">\n"
+ " </div>\n\n"
+ " <p>This \"image3.png\" is not linked so it should be ignored</>\n"
+ " <p>This \"app.js\" is not linked so it should be ignored</>\n"
+ " <p>This \"style.css\" is not linked so it should be ignored</>\n\n"
+ " <script src=\"app.js\"></script>\n"
+ "</body>\n\n"
+ "</html>\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}