import Foundation
let pattern = #"(?:href=|src=|url\()(?:[\",']?)(.*image3\.png)[\",',\)]+?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8" />
<title></title>
<meta name="description" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="stylesheet" type="text/css" href="style.css" />
</head>
<body>
<div class="wrapper">
<img src="image1.png" alt="description goes here">
<img src="image2.png" alt="description goes here">
<img src="image3.png" alt="description goes here">
</div>
<p>This "image3.png" is not linked so it should be ignored</>
<p>This "app.js" is not linked so it should be ignored</>
<p>This "style.css" is not linked so it should be ignored</>
<script src="app.js"></script>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)