re = /(?:href=|src=|url\()(?:[\",']?)(.*image3\.png)[\",',\)]+?/
str = '<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8" />
<title></title>
<meta name="description" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="stylesheet" type="text/css" href="style.css" />
</head>
<body>
<div class="wrapper">
<img src="image1.png" alt="description goes here">
<img src="image2.png" alt="description goes here">
<img src="image3.png" alt="description goes here">
</div>
<p>This "image3.png" is not linked so it should be ignored</>
<p>This "app.js" is not linked so it should be ignored</>
<p>This "style.css" is not linked so it should be ignored</>
<script src="app.js"></script>
</body>
</html>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end