using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=house with name (?:=|in) \"")[^\""]+(?=\"")|(?<=house with name (?:=|in) \()[^()]+(?=\))";
string input = @"house with name = ""avilla""
house with name in (""avilla"",""bvilla"") house with name in (""avilla"",""bvilla"")
house with name in (""avilla"",""bvilla"" house with name in (""avilla"",""bvilla"")
house with name in (""avilla"",""bvilla";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}