const regex = new RegExp('(?<=house with name (?:=|in) \\")[^\\"]+(?=\\")|(?<=house with name (?:=|in) \\()[^()]+(?=\\))', 'gm')
const str = `house with name = "avilla"
house with name in ("avilla","bvilla") house with name in ("avilla","bvilla")
house with name in ("avilla","bvilla" house with name in ("avilla","bvilla")
house with name in ("avilla","bvilla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}