re = /(?<=house with name (?:=|in) \")[^\"]+(?=\")|(?<=house with name (?:=|in) \()[^()]+(?=\))/m
str = 'house with name = "avilla"
house with name in ("avilla","bvilla") house with name in ("avilla","bvilla")
house with name in ("avilla","bvilla" house with name in ("avilla","bvilla")
house with name in ("avilla","bvilla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end