import re
regex = re.compile(r"(?<=house with name (?:=|in) \")[^\"]+(?=\")|(?<=house with name (?:=|in) \()[^()]+(?=\))", flags=re.MULTILINE)
test_str = ("house with name = \"avilla\"\n"
"house with name in (\"avilla\",\"bvilla\") house with name in (\"avilla\",\"bvilla\")\n"
"house with name in (\"avilla\",\"bvilla\" house with name in (\"avilla\",\"bvilla\")\n"
"house with name in (\"avilla\",\"bvilla")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")