$re = '/(?<=house with name (?:=|in) \")[^\"]+(?=\")|(?<=house with name (?:=|in) \()[^()]+(?=\))/m';
$str = 'house with name = "avilla"
house with name in ("avilla","bvilla") house with name in ("avilla","bvilla")
house with name in ("avilla","bvilla" house with name in ("avilla","bvilla")
house with name in ("avilla","bvilla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);