import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=house with name (?:=|in) \\\")[^\\\"]+(?=\\\")|(?<=house with name (?:=|in) \\()[^()]+(?=\\))";
final String string = "house with name = \"avilla\"\n"
+ "house with name in (\"avilla\",\"bvilla\") house with name in (\"avilla\",\"bvilla\")\n"
+ "house with name in (\"avilla\",\"bvilla\" house with name in (\"avilla\",\"bvilla\")\n"
+ "house with name in (\"avilla\",\"bvilla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}