using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([а-яё]+)(,|;|!|\.|\?|\:)([а-яё])";
string input = @"Нет пробела после запятой,Либо после точки с запятой;а иногда и даже после таких знаков:восклицательного!И даже вопросительного.Найдет ли мой скрипт такую ошибку?Посмотрим.
""Жи"" и ""ши"" мы пишем с буквой ""и"" в словах ""шына"", ""жывотное"" и др.
В тексте есть слово ""координально"", ""сдесь"", ""зделал"", ""зделан"" а также ""зделаю"" но нет слова ""чюдо"" и ""щюка";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}