import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([а-яё]+)(,|;|!|\\.|\\?|\\:)([а-яё])";
final String string = "Нет пробела после запятой,Либо после точки с запятой;а иногда и даже после таких знаков:восклицательного!И даже вопросительного.Найдет ли мой скрипт такую ошибку?Посмотрим.\n"
+ "\"Жи\" и \"ши\" мы пишем с буквой \"и\" в словах \"шына\", \"жывотное\" и др.\n"
+ "В тексте есть слово \"координально\", \"сдесь\", \"зделал\", \"зделан\" а также \"зделаю\" но нет слова \"чюдо\" и \"щюка";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}