# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([а-яё]+)(,|;|!|\.|\?|\:)([а-яё])"
test_str = ("Нет пробела после запятой,Либо после точки с запятой;а иногда и даже после таких знаков:восклицательного!И даже вопросительного.Найдет ли мой скрипт такую ошибку?Посмотрим.\n"
"\"Жи\" и \"ши\" мы пишем с буквой \"и\" в словах \"шына\", \"жывотное\" и др.\n"
"В тексте есть слово \"координально\", \"сдесь\", \"зделал\", \"зделан\" а также \"зделаю\" но нет слова \"чюдо\" и \"щюка")
matches = re.finditer(regex, test_str, re.UNICODE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.