$re = '/([а-яё]+)(,|;|!|\.|\?|\:)([а-яё])/ui';
$str = 'Нет пробела после запятой,Либо после точки с запятой;а иногда и даже после таких знаков:восклицательного!И даже вопросительного.Найдет ли мой скрипт такую ошибку?Посмотрим.
"Жи" и "ши" мы пишем с буквой "и" в словах "шына", "жывотное" и др.
В тексте есть слово "координально", "сдесь", "зделал", "зделан" а также "зделаю" но нет слова "чюдо" и "щюка';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);