// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ui)([а-яё]+)(,|;|!|\.|\?|\:)([а-яё])").unwrap();
let string = "Нет пробела после запятой,Либо после точки с запятой;а иногда и даже после таких знаков:восклицательного!И даже вопросительного.Найдет ли мой скрипт такую ошибку?Посмотрим.
\"Жи\" и \"ши\" мы пишем с буквой \"и\" в словах \"шына\", \"жывотное\" и др.
В тексте есть слово \"координально\", \"сдесь\", \"зделал\", \"зделан\" а также \"зделаю\" но нет слова \"чюдо\" и \"щюка";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}