package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([а-яё]+)(,|;|!|\.|\?|\:)([а-яё])`)
var str = `Нет пробела после запятой,Либо после точки с запятой;а иногда и даже после таких знаков:восклицательного!И даже вопросительного.Найдет ли мой скрипт такую ошибку?Посмотрим.
"Жи" и "ши" мы пишем с буквой "и" в словах "шына", "жывотное" и др.
В тексте есть слово "координально", "сдесь", "зделал", "зделан" а также "зделаю" но нет слова "чюдо" и "щюка`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}