package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+(?:\s*x\s*[0-9]+)+\s*`)
var str = `16 x 13 x 12 inch box
1x2x3 pipe
123x 23 x334 asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}