const regex = /^[0-9]+(?:\s*x\s*[0-9]+)+\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+(?:\\s*x\\s*[0-9]+)+\\s*', 'gm')
const str = `16 x 13 x 12 inch box
1x2x3 pipe
123x 23 x334 asd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}