import re
regex = re.compile(r"^[0-9]+(?:\s*x\s*[0-9]+)+\s*", flags=re.MULTILINE)
test_str = ("16 x 13 x 12 inch box\n"
"1x2x3 pipe\n"
"123x 23 x334 asd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")