$re = '/^[0-9]+(?:\s*x\s*[0-9]+)+\s*/m';
$str = '16 x 13 x 12 inch box
1x2x3 pipe
123x 23 x334 asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);