re = /^[0-9]+(?:\s*x\s*[0-9]+)+\s*/m
str = '16 x 13 x 12 inch box
1x2x3 pipe
123x 23 x334 asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end