using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,4}\s*[a-zA-Z]+";
string input = @"San Diego County, California
4150 Ute Dr, San Diego, California
Vista del Lago, Perris, California, 92570";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}