const regex = new RegExp('\\d{1,4}\\s*[a-zA-Z]+', 'gm')
const str = `San Diego County, California
4150 Ute Dr, San Diego, California
Vista del Lago, Perris, California, 92570`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}