package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,4}\s*[a-zA-Z]+`)
var str = `San Diego County, California
4150 Ute Dr, San Diego, California
Vista del Lago, Perris, California, 92570`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}