$re = '/\d{1,4}\s*[a-zA-Z]+/m';
$str = 'San Diego County, California
4150 Ute Dr, San Diego, California
Vista del Lago, Perris, California, 92570';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);