re = /\d{1,4}\s*[a-zA-Z]+/m
str = 'San Diego County, California
4150 Ute Dr, San Diego, California
Vista del Lago, Perris, California, 92570'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end