// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,4}\s*[a-zA-Z]+").unwrap();
let string = "San Diego County, California
4150 Ute Dr, San Diego, California
Vista del Lago, Perris, California, 92570";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}