#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\w+)\s+(?:(\d{4})\s+(\d{1,2})|(\d{1,2})\s+(\d{4}))"
Local $sString = "Text 01 2018" & @CRLF & _
"Text 2 2019" & @CRLF & _
"Text 2020 03" & @CRLF & _
"Text 2021 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")