const regex = new RegExp('(?:\\w+)\\s+(?:(\\d{4})\\s+(\\d{1,2})|(\\d{1,2})\\s+(\\d{4}))', 'gm')
const str = `Text 01 2018
Text 2 2019
Text 2020 03
Text 2021 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}