$re = '/(?:\w+)\s+(?:(\d{4})\s+(\d{1,2})|(\d{1,2})\s+(\d{4}))/m';
$str = 'Text 01 2018
Text 2 2019
Text 2020 03
Text 2021 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);