import re
regex = re.compile(r"(?:\w+)\s+(?:(\d{4})\s+(\d{1,2})|(\d{1,2})\s+(\d{4}))", flags=re.MULTILINE)
test_str = ("Text 01 2018\n"
"Text 2 2019\n"
"Text 2020 03\n"
"Text 2021 4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")