package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w+)\s+(?:(\d{4})\s+(\d{1,2})|(\d{1,2})\s+(\d{4}))`)
var str = `Text 01 2018
Text 2 2019
Text 2020 03
Text 2021 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}