// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\w+)\s+(?:(\d{4})\s+(\d{1,2})|(\d{1,2})\s+(\d{4}))").unwrap();
let string = "Text 01 2018
Text 2 2019
Text 2020 03
Text 2021 4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}