package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<[ \t]*begin[ \t]>[^<]*([\s\S]*?)^<[ \t]*end[ \t]*>`)
var str = `< begin >
< datapt > 1 < datapt >
< xunit > mass < xunit >
< xval > 150.000097 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >
< begin >
< datapt > 2 < datapt >
< xunit > mass < xunit >
< xval > 150.000245 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}