use strict;
my $str = '< begin >
< datapt > 1 < datapt >
< xunit > mass < xunit >
< xval > 150.000097 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >
< begin >
< datapt > 2 < datapt >
< xunit > mass < xunit >
< xval > 150.000245 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >';
my $regex = qr/^<[ \t]*begin[ \t]>[^<]*([\s\S]*?)^<[ \t]*end[ \t]*>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}