# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^<[ \t]*begin[ \t]>[^<]*([\s\S]*?)^<[ \t]*end[ \t]*>"
test_str = ("< begin >\n"
" < datapt > 1 < datapt >\n"
" < xunit > mass < xunit >\n"
" < xval > 150.000097 < xval >\n"
" < yunit > abs < yunit >\n"
" < yval > 0.000000 < yval >\n"
"< end >\n\n"
"< begin >\n"
" < datapt > 2 < datapt >\n"
" < xunit > mass < xunit >\n"
" < xval > 150.000245 < xval >\n"
" < yunit > abs < yunit >\n"
" < yval > 0.000000 < yval >\n"
"< end >")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.