$re = '/^<[ \t]*begin[ \t]>[^<]*([\s\S]*?)^<[ \t]*end[ \t]*>/m';
$str = '< begin >
< datapt > 1 < datapt >
< xunit > mass < xunit >
< xval > 150.000097 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >
< begin >
< datapt > 2 < datapt >
< xunit > mass < xunit >
< xval > 150.000245 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);