// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^<[ \t]*begin[ \t]>[^<]*([\s\S]*?)^<[ \t]*end[ \t]*>").unwrap();
let string = "< begin >
< datapt > 1 < datapt >
< xunit > mass < xunit >
< xval > 150.000097 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >
< begin >
< datapt > 2 < datapt >
< xunit > mass < xunit >
< xval > 150.000245 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >
< end >";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}