#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\b(?:(?!te2st\/index\.js)\w)+\b$"
Local $sString = "snap/0ad/206/.local/share/0ad/replays/0.0.24/test/index.js" & @CRLF & _
"snap/0ad/206/.local/share/0ad/replays/0.0.24/te2st/index.js" & @CRLF & _
"snap/0ad/206/.local/share/0ad/replays/0.0.24/te3t/index.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")