const regex = /^.*\b(?:(?!te2st\/index\.js)\w)+\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\b(?:(?!te2st\\\/index\\.js)\\w)+\\b$', 'gm')
const str = `snap/0ad/206/.local/share/0ad/replays/0.0.24/test/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te2st/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te3t/index.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}