re = /^.*\b(?:(?!te2st\/index\.js)\w)+\b$/m
str = 'snap/0ad/206/.local/share/0ad/replays/0.0.24/test/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te2st/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te3t/index.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end