use strict;
my $str = 'snap/0ad/206/.local/share/0ad/replays/0.0.24/test/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te2st/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te3t/index.js';
my $regex = qr/^.*\b(?:(?!te2st\/index\.js)\w)+\b$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}