import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\b(?:(?!te2st\\/index\\.js)\\w)+\\b$";
final String string = "snap/0ad/206/.local/share/0ad/replays/0.0.24/test/index.js\n"
+ "snap/0ad/206/.local/share/0ad/replays/0.0.24/te2st/index.js\n"
+ "snap/0ad/206/.local/share/0ad/replays/0.0.24/te3t/index.js";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}