using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\b(?:(?!te2st\/index\.js)\w)+\b$";
string input = @"snap/0ad/206/.local/share/0ad/replays/0.0.24/test/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te2st/index.js
snap/0ad/206/.local/share/0ad/replays/0.0.24/te3t/index.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}