#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\S{2})\S*$|(?:^| *)(\S)\S* *"
Local $sString = "Elon Musk" & @CRLF & _
"Elon musk" & @CRLF & _
"Elon"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)