use strict;
my $str = 'Elon Musk
Elon musk
Elon';
my $regex = qr/^(\S{2})\S*$|(?:^| *)(\S)\S* */mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";