using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S{2})\S*$|(?:^| *)(\S)\S* *";
string substitution = @"$1$2";
string input = @"Elon Musk
Elon musk
Elon";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}