$re = '/^(\S{2})\S*$|(?:^| *)(\S)\S* */m';
$str = 'Elon Musk
Elon musk
Elon';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;