package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S{2})\S*$|(?:^| *)(\S)\S* *`)
var str = `Elon Musk
Elon musk
Elon`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}